CodeCharge Studio
search Register Login  

Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> .NET

 Weird behavior on only 1 page

Print topic Send  topic

Author Message
AndyGB4

Posts: 121
Posted: 10/09/2013, 11:35 AM

Hi, I've been getting some weird behavior on a certain page of mine.
The HTML code is being changed by CodeCharge in ways I've never seen before and it's causing problems.

For example, in the header, I am supposed to have this line of code:
<title>Admin Side - {res:Artists}</title>

But when I save and publish, it changes the HTML to this:
<title>Admin Side - <span ccsServiceable="true" ccsType="Resource" ccsResourceName="artists" style="white-space:nowrap;border-color:#bbbbbb;border-style:solid;border-width:1px" ccsResourcePrefix="res" contentEditable="false" >res:artists</span></title>

And also, in a grid on that same page, I'm using CSS styles on alternate rows. And normally it generates this code (which is generated by CodeCharge):
<tr {artistGrid:rowStyle}>

But instead, it's giving me this:
<tr {artistgrid:rowstyle}="">
It takes away the uppercase letters, causing issues. and also adds ="" to the end of it...

Has anyone seen this weird behavior before?
View profile  Send private message
eratech


Posts: 513
Posted: 01/06/2014, 8:27 PM

Hi Andy - I just noticed you posted a similar problem in the .NET Inmotion forum

I'm guessing there still isn't any resolution to the above renaming?

I've had a couple of problems with an original CCS 4.1 project that we upgraded to CCS 5 - mostly with some little quirks, it is not Inmotion though.

On about 4 pages (from 80 in the project), changes to the Design/HTML wouldn't automatically update to the ASPX (but 'cut' out all the ASPX code, and re-gen sorted it, but was a pain for every change)

Not renaming though - that is a new one. I will keep an eye out for it.

Cheers

Eric
_________________
CCS 3/4/5 ASP Classic, VB.NET, PHP
Melbourne, Victoria, Australia
View profile  Send private message
AndyGB4

Posts: 121
Posted: 01/07/2014, 10:34 AM

Hi Eric,

wow, it's been lingering for so long I forgot I even posted in the .NET forum as well!

My InMotion project was created in CCS5, and now I'm getting the issue on any new page that I create. Still no news from Support either... So still no resolution. For now, I have to publish, then correct the spelling, and publish again. It's a time waster, but at least I can still make some changes to the page.



View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

PHP Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.