CodeCharge Studio
search Register Login  

Visual PHP Web Development

Visually Create Internationalized Web Applications, Web Reports, Calendars, and more.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> General/Other

 Publishing very, very slow.

Print topic Send  topic

Author Message
saseow

Posts: 710
Posted: 03/12/2018, 8:50 PM Quote message

Using Win 10 Home 64.
XAMPP running PHP and Apache.
Separate MySQL.
Problem:
1) More often than not I have to refresh the browser in order to connect. Standard message when it does not connect is "Database error: cannot connect to Database A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
MySQL Error
Session halted."
2) Publishing a page in CCS takes a long time and once the page has been published, CCS takes a few minutes in Unresponsive state before returning to normal. Generating a page is fast as usual.
I have tried every variation of the following with no luck so hope someone on the forum has had the same hassle and fixed it.
Localhost vs 127.0.0,0.1. Both resolve just fine.
Loading pure HTML site in browser is fast.
Playing with IPv4 and IPv6 makes no difference.
Adding and changing items in Apache cnf file and MySQL ini file makes no difference.
Since this has all been working perfectly for months, I can only presume that some Windows update has changed something obscure.
If anyone has any ideas on this please share them! Thanks.
View profile  Send private message
DataDoIT
Posted: 03/13/2018, 5:34 PM Quote message

Check your database connection. You're probably connecting to a remote
database (not on your local computer and XAMPP), thus the slow responses.

Quick and dirty... browse to your C:\xampp\htdocs\website\ and open
Common.php to see what the database connection is. Should be localhost.
saseow

Posts: 710
Posted: 03/13/2018, 9:44 PM Quote message

Thanks for the reply but the connection is localhost. AS I mentioned, sometimes it works but most of the time I have to refresh the browser before it connects. The publishing slow-down is for common files. A Quick Publish of a page is fast.
Very strange.
View profile  Send private message

Add new topic Reply to topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Web Database

Join thousands of Web developers who build Web applications with minimal coding.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.