CodeCharge Studio
search Register Login  

Visual PHP Web Development

Visually Create Internationalized Web Applications, Web Reports, Calendars, and more.
CodeCharge.com

YesSoftware Forums -> Archive -> CodeChargeStudio.Discussion

 "Class not registered" error

Print topic Send  topic

Author Message
Rene
Posted: 01/06/2004, 1:17 PM

I am developing a small project in ASP 3.0. I develop it on my computer and
it works fine. It also worked fine on the IIS production server. However as
I had all the pages in the same level (directory), I created subdirectories
and moved some of the pages there. I adjusted some of the links that were
not automatically adjusted. Now the project is running my computer, but some
pages are not running anymore on the production server. I get an error
"Class not registered":

Error Type:
Provider (0x80040154)
Class not registered
/sales/Classes.asp, line 2511

That line has the following code that is part of the clsCommand Class, in
the Function DoOpen():

"DataSource.Recordset.Open"

The funny thing is that one of the pages that is not running, has several
Grid forms an a Search record form. When I delete some of the controls of
the Search record form (but noone in particular) or all the Search record
form, the page starts running again. I have looked everywhere for a fix but
I don't find it. BTW in the same project I have other pages with Search and
Grid forms that run perfectly.

Any idea where the error can be located?


Rene


   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Internet Database

Visually create Web enabled database applications in minutes.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.