CodeCharge Studio
search Register Login  

Web Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> PHP

 CCS-PHP-APache Connection

Print topic Send  topic

Author Message
Casper

Posts: 7
Posted: 01/27/2004, 1:07 PM

Hi All,

Sorry for another noob question:

If anyone can help. I've bought codecharge than upgraded to CCS but never use it and would love to learn finally.

OK the version I'm using is current of CCS, I'm creating a small project in php format. The localhost runs Foxserv distribution of Apache, mysql and PHP on Win XP pro.

Within CCS connections, how does one setup to run locally in design mode and via locally on the server?

I'm getting these errors.

Database error: cannot use database DSN=amcppx;DESC=MySQL ODBC 3.51 Driver DSN;DATABASE=serverswk;SERVER=localhost;UID=vano;PASSWORD=test;PORT=3306;OPTION=3;STMT=;
MySQL Error: 1102 (Incorrect database name 'DSN=amcppx;DESC=MySQL ODBC 3.51 Driver DSN;DATABASE=serverswk;SERVER=localhost;UID=vano;PASSWORD=')
Session halted.

DSN seems to be tested fine, but the errors appears when you attempt a live page view or browser view.

I've used Db apps to view the database etc seems fine. DNS test via DNS setup looks ok.

Any help appreciated.

Regards,

Joe :-<
View profile  Send private message
peterr


Posts: 5971
Posted: 01/27/2004, 5:58 PM

Can you please open your Connection in CCS and go to "Server" tab, then try these two solutions:
1. Select "PHP Database Library" as "MySQL", then enter the name of your database into the "Database or ODBC connection name" field.

or
2. Select "PHP Database Library" as "ODBC | MySQL", then enter the name of your local ODBC/DSN Connection the "Database or ODBC connection name" field. In this case pleae also make sure that yuo are using System DSN, not User DSN (see http://exact-me.org/ri/documentation/set_db_as_system_dsn.htm , although this is not about MySQL).

_________________
Peter R.
YesSoftware Forums Moderator
For product support please visit http://support.yessoftware.com
View profile  Send private message
Casper

Posts: 7
Posted: 01/27/2004, 10:56 PM

Hi Peter,

Thanks for the help, looks like I set both User and System DSN which was in conflict. Removed the User DSN and all works great. Now some more learning of CSS.... thanks a bunch!

Regards,

Joe
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Web Database

Join thousands of Web developers who build Web applications with minimal coding.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.