CodeCharge Studio
search Register Login  

Visual Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge -> General/Other

 Analyst

Print topic Send  topic

Author Message
Henryk
Posted: 02/17/2004, 8:27 AM

I created a search form and record editing form using the application buider. When I click on the link for a record from the search page, rather than opening that record it appears to open a blank/new record. I am guessing I missed something pretty obvious, but where would I go to fix it so that it pulls that record up for editing when you click on the link to the record from the search page. I tried building it twice in application builder, the second time I was very conscientous to make sure anything that implied being able to edit records was checked. Thank you!

Henryk
Nicole

Posts: 586
Posted: 02/18/2004, 5:40 AM

Henryk,
To set a form into edit mode you should pass primary to it. It may happen that in your case primary key field is not in a list of fields of SELECT query and thus it cannot be passed via URL.
Open grid form Data Source dialog-> click Build Query and make sure that primary key flag in a list of fields is selected.

BTW, it seems to be CCS question, not CC.

_________________
Regards,
Nicole
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

PHP Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.