CodeCharge Studio
search Register Login  

Visual PHP Web Development

Visually Create Internationalized Web Applications, Web Reports, Calendars, and more.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> ColdFusion

 Grid Builder

Print topic Send  topic

Author Message
Graham Pearson
Posted: 06/02/2004, 5:06 AM

Has anyone else had an issue with grid builder. Here is my problem.

One one page I have 1 Grid builder which I pull all of the school
corporations within the state of indiana who's corporation number is
a specific number. The value comes from a session variable which I
called session.userinfo.corp_id and for this example lets say the
value is 9570.

When I publish this page and look in the debug section, this query is
correct and everything works which this pulls up 1 record and it
should.



Now I have tried to add a second grid builder right beneath the one
for the corporation information but this time this one will pull up
all of the school buildings which has the corpNumber of the
corporation that is displayed in the previous grid builder. With the
query being correct as it has the same where clause as the
corp_mainInfo which is the first query builder on this page, when I
save and publish this page and look at the debug information the
CALLER.queryschool_mainInfo does not have the where clause and is
pulling in all records from the table.

Also just noticed that within the debug of the sql query from
CCOpenRS.cfm that the select line has duplicated all field that I am
displaying on the screen.

Example:

Select CorpNumber, CorpName, CorpMainAddress, CorpMainCity,
CorpMainState, CorpMainZip, CorpNumber, CorpName, CorpMainAddress,
CorpMainCity, CorpMainState, CorpMainZip From corp_mainInfo Where
CorpNumber = 9570 Order by CorpName



---

Graham Pearson, System Administrator/Webmaster

Northern Indiana Educational Services Center

Http://www.niesc.k12.in.us
Graham Pearson
Posted: 06/02/2004, 5:48 AM

More Information regarding this. I have just found out that if I set
a default value when the values is blank it will always use that
value I set. If I create a Label at the end of the page to diplay the
value it will be correct. Why does the second grid builder now
include the where clause of the sql statement like the first grid
builder does. Is it possible that you can not have 2 grid builders on
the same page displaying results from 2 different tables within the
same database connection?

> Has anyone else had an issue with grid builder. Here is my problem.

>

> One one page I have 1 Grid builder which I pull all of the school

> corporations within the state of indiana who's corporation number
is

> a specific number. The value comes from a session variable which I

> called session.userinfo.corp_id and for this example lets say the

> value is 9570.

>

> When I publish this page and look in the debug section, this query
is

> correct and everything works which this pulls up 1 record and it

> should.

>

>

>

> Now I have tried to add a second grid builder right beneath the one


> for the corporation information but this time this one will pull up


> all of the school buildings which has the corpNumber of the

> corporation that is displayed in the previous grid builder. With
the

> query being correct as it has the same where clause as the

> corp_mainInfo which is the first query builder on this page, when I


> save and publish this page and look at the debug information the

> CALLER.queryschool_mainInfo does not have the where clause and is

> pulling in all records from the table.

>

> Also just noticed that within the debug of the sql query from

> CCOpenRS.cfm that the select line has duplicated all field that I
am

> displaying on the screen.

>

> Example:

>

> Select CorpNumber, CorpName, CorpMainAddress, CorpMainCity,

> CorpMainState, CorpMainZip, CorpNumber, CorpName, CorpMainAddress,

> CorpMainCity, CorpMainState, CorpMainZip From corp_mainInfo Where

> CorpNumber = 9570 Order by CorpName

>

>

---

Graham Pearson, System Administrator / Web Developer

Northern Indiana Educational Services Center

56535 Magnetic Drive, Mishawaka IN 46544

http://www.niesc.k12.in.us
E43509

Posts: 283
Posted: 06/15/2004, 8:59 AM

Not seen this problem but don't have two grids on the same page
View profile  Send private message
E43509

Posts: 283
Posted: 08/26/2004, 7:07 AM

Just antoher data point, I've seen something similar when using the grid builder and all of my fields are duplicated (in design mode). I've also seen funny sql generated with dups. When that happens, I turn in a ticket to CCS and I change from using table to sql and write my own string. That cures a lot of woes.
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

PHP Reports

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.