CodeCharge Studio
search Register Login  

Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> Perl

 Separating style sheets and cgi-bin (also permissions)

Print topic Send  topic

Author Message
dhempy


Posts: 40
Posted: 06/15/2004, 11:21 PM

I am evaluating CodeCharge Studio, and am quite impressed so far.

I've run into a problem I can't figure out. I'm generating a perl application. When I publish it, it goes under /cgi-bin/ (Running Apache on Linux). I was quite surprised that CCS didn't set the executable permissions on the .cgi files, but I fixed that. Did I miss a setting for this? Surely everyone else is having the same problem.

The thing I can't figure out is the style sheets. They are pubilshed under /cgi-bin/Themes/... They cannot be served from this location. Apache attempts to execute them, which of course is not what we want. The result is all the pages are unstyled black-on-white text.

How can I tell CCS to publish the .css files under /html/, not under /cgi-bin/? This seems so obvious, I must be missing something. This will be a deal-killer if there is not a solution.

Thanks in advance,
-dave


_________________
David Hempy
Director of Broadcast and Education Technology
Kentucky Educational Television
800-333-9764
View profile  Send private message
jeff scott
Posted: 06/25/2004, 12:42 AM

this really comes down to an apache configuration issue....but i agree, i normally want my cgis and html files in separte directories with sepeate access permissions....

i don't have this paticular problem because i have the Add Handler .cgi directive enabled on the virtual host to allow cgi exec outside the script alias.

you should be able to repoint the $TemplateFileName to ../html or whatever, however, i'm having issues getting this to work correctly.
Alibae Newkirk
Posted: 02/08/2005, 11:50 AM

:-P
I love Code Charge Studio. I have used it entirely to create my site and many others. This is the enviroment that Code Charge Studio works best for me. I have Abyss Web Server running with a cgi. alias directory inside of my htdocs folder so that I can both execute it without any permission problems and edit the HTML with dreamweaver using site-wide templates. I recomend using a web-server that fits your needs. Like I tell lil old ladies at my computer store, why would I sell you a top-shelf machine, just for you to email your grand-daughter. Apache is the end-all be-all of servers but if you really dont need all the bells and whistles, use Abyss, or something else. My light-weight Abyss enviroment works very well for developing CCS apps. Also check your root folder permissions, usually docs will adopt the permissions of the parent folder. PS alibae.com check me out!
roeya


Posts: 181
Posted: 02/09/2005, 12:48 AM

As jeff scott said - just re-configure apache - I use the following way for apache 1.3XX:

Alias /sitename/cgi/ /home/www/sitename/cgi/

<Directory "/home/www/sitename/cgi">
Options +ExecCGI
AllowOverride None
Order allow,deny
Allow from all
AddHandler cgi-script .pl
</Directory>

It ensures that everything is accessible (images, styles, scripts etc...)

Anyway the tech support of Yes Software are well aware about this issue, and I am following the advice they gave me.


_________________
http://www.infoneto.com/
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

Web Database

Join thousands of Web developers who build Web applications with minimal coding.
CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.