CodeCharge Studio
search Register Login  

Web Reporting

Visually create Web Reports in PHP, ASP, .NET, Java, Perl and ColdFusion.
CodeCharge.com

YesSoftware Forums -> CodeCharge Studio -> .NET

 Newbie: Problems with Authentication forms etc.

Print topic Send  topic

Author Message
jimlocigno

Posts: 14
Posted: 11/11/2004, 6:51 PM

1) As a learning experince I have created a very simple database (two tables and one form for each table).
2) The data entry forms and search work fine.
3) However, I have also created a Login Page. The form in 1) and 2) are set to restricted. When I try and access one of those forms:
http://localhost/vtrack/days_off.aspx  
- I get "Page not found" and the URL in is set to
http://localhost/vtrack/vtrack_login?ret_link=%2fvtrack%2fdays_off.aspx%3f
4) When I call the login page directly and sign in with an acceptable userid/password I get the same error as above and the same URL in the address box. The URL for a given page in my database is http://locahost/vtrack/vtrack.aspx and judging from the URL returned above I believe the URL returned is correct but I don't why it says "page not found". What am I missing? Thanks

Sorry about the long question. Any help would be apreciated.

View profile  Send private message
peterr


Posts: 5971
Posted: 11/11/2004, 7:00 PM

Hi,

http://localhost/vtrack/vtrack_login
looks invalid because it should end with .aspx.
Looks like some settings somewhere are not specified correctly. Maybe "vtrack_login" page doesn't exist, or in project settings you typed "vtrack_login" rather then selecting an actual page.
_________________
Peter R.
YesSoftware Forums Moderator
For product support please visit http://support.yessoftware.com
View profile  Send private message
jimlocigno

Posts: 14
Posted: 11/11/2004, 7:14 PM

Thanks very much for your quick reply (< 5mins) I really was not expecting an answer until tomorrow.

Anyway, the good news is you were correct, I did not specifcy the page correctly in Project Settings. So now I no longer get that page not found but the bad news is when I sign it does not redirect me the requested page. No matter what it brings me back to the login page. I know I am signing in correctly because if I a put an invalid user/id in the login page in properly returns
The value in field password is required.
Thanks
Jim
View profile  Send private message
peterr


Posts: 5971
Posted: 11/11/2004, 10:57 PM

Hmm, did you specify the destination page in the "Return Page" property of the Login form?
If so, then possibly the cookies are tured off in the browser. Are you able to login to other Websites from the same browser?
_________________
Peter R.
YesSoftware Forums Moderator
For product support please visit http://support.yessoftware.com
View profile  Send private message
jimlocigno

Posts: 14
Posted: 11/13/2004, 6:46 AM

Sorry it took be so long to get back. Anyway, yes the return page is specified in the Login Form and as far as I can tell cookies ARE turned on in the browser. I tried it from another computer and get the same results?

Thanks
View profile  Send private message
peterr


Posts: 5971
Posted: 11/13/2004, 9:02 AM

OK. If you don't hear from anyone else here try contacting the support. Someone may need to take a look at your page.
_________________
Peter R.
YesSoftware Forums Moderator
For product support please visit http://support.yessoftware.com
View profile  Send private message
jimlocigno

Posts: 14
Posted: 11/13/2004, 3:31 PM

Okay - I will contact support if necessary but I am not holding much hope for that. The last two times I contacted support (through the online form) I have received NO response. But I will give it try if I need to.
View profile  Send private message
peterr


Posts: 5971
Posted: 11/13/2004, 3:38 PM

I don't think that its possible that we wouldn't send you a response. Our system shows all overdue tickets/cases and currently we don't have any. You'd also get the automated response as soon as you submit the question. Please provide another email address when submitting the next support case if you are not receiving our emails at the email address you originally submitted.
_________________
Peter R.
YesSoftware Forums Moderator
For product support please visit http://support.yessoftware.com
View profile  Send private message

Add new topic Subscribe to topic   


These are Community Forums for users to exchange information.
If you would like to obtain technical product help please visit http://support.yessoftware.com.

MS Access to Web

Convert MS Access to Web.
Join thousands of Web developers who build Web applications with minimal coding.

CodeCharge.com

Home   |    Search   |    Members   |    Register   |    Login


Powered by UltraApps Forum created with CodeCharge Studio
Copyright 2003-2004 by UltraApps.com  and YesSoftware, Inc.